flagflag  If you want to see English page, please click "English" Button at Left.

OSProfiles

  • このフォーラムに新しいトピックを立てることはできません
  • このフォーラムではゲスト投稿が禁止されています

なし OSProfiles

msg# 1
前の投稿 - 次の投稿 | 親投稿 - 子投稿.1 .2 .3 .4 .5 .6 .7 .8 .9 .10 .11 .12 .13 .14 .15 .16 .17 | 投稿日時 2010-7-24 18:01
skidz  Not too shy to talk   投稿数: 31
Trying to get OSProfiles to work..

But every time I click ok I get the following message, and nothing is saved...
"Unable to search at this time"

I tried several methods to set it up.. but what I did was
cp -rf $srcDirectory/xoopensim/source/xoopensim/osprofile/* $srcDirectory/opensim/source/opensim/addon-modules/
cd $srcDirectory/opensim/source/opensim/addon-modules/
./build.sh 0.7
cd $srcDirectory/opensim/source/opensim/
./runprebuild.sh
nant

the dll is created... so I think I am doing it right... any ideas on what I might be doing wrong?
投票数:107 平均点:5.33

なし Re: OSProfiles

msg# 1.1
前の投稿 - 次の投稿 | 親投稿 - 子投稿なし | 投稿日時 2010-7-24 18:58
skidz  Not too shy to talk   投稿数: 31
Oh.. I thought I should mention that I did edit the ini file need to and place it in
addon-modules/OpenSimProfile/config/OpenSim-addition.ini
which gets included in the OpenSim.ini automatically with the filter
Include-modules = "addon-modules/*/config/*.ini"

;Add the following to your own OpenSim.ini file to make the UserProfile service working
[Profile]
; Change it to your own HTTP server to have the Profile server work
ProfileURL = http://192.168.1.97/modules/xoopensim/helper/profile.php

I also tried adding this directly to OpenSim.ini and made no difference. But I also get the same error when its wrong as well..
投票数:111 平均点:6.76

なし Re: OSProfiles

msg# 1.2
前の投稿 - 次の投稿 | 親投稿 - 子投稿なし | 投稿日時 2010-7-25 0:15
master  Just can't stay away   投稿数: 138
Well the short answer is search must be made happy before osprofiles will work. They go hand in hand with each other.
to know if search is happy, make shure that users and groups show up in search all. If Only groups do and no users then
you need to solve that 1st. The message its giving you is the clue. Once you have search working Profiles will fall in line.
I was able to make Ossearch +Osprofile work but remeber that nether is fully functional untill stats are fixed. But in my tests it works well enough.
Anyway i think if you make search happy you will also make profiles happy.
Also remember that your .69 versions of add-on modules are not the same ones as in forge svn trunk. The ones in trunk are updated for rev's > .69 and will not work in .69. I keep archives of forge projects so i still have both if needed.

Id love it if someday they would just combine the 2 projects as one, this is another reaison they should as one no good with out the other anyway.
投票数:101 平均点:3.47

なし Re: OSProfiles

msg# 1.3
前の投稿 - 次の投稿 | 親投稿 - 子投稿なし | 投稿日時 2010-7-25 0:26
master  Just can't stay away   投稿数: 138
Now that .7 Release is out you might be better off waiting a bit for things to catch up to it. Some of these things have been altered to the point new add-on's will prob. need to be made anyway.

Gotta love progress lol
投票数:162 平均点:2.47

なし Re: OSProfiles

msg# 1.4
前の投稿 - 次の投稿 | 親投稿 - 子投稿なし | 投稿日時 2010-7-25 4:49
skidz  Not too shy to talk   投稿数: 31
Hi Mater...
I actually do have search working for groups and people, but maybe I did it in the wrong way...

How I did it...
1. download the ossearch...
svn checkout --username anonymous http://forge.opensimulator.org/svn/ossearch
2. Created a database for it named osmodules
3. Pointed the databaseinfo.php to the new database
4. Moved the module to the opensim/addon-module folder
5. compiled
6. added the ini to bin/addon-modules/ossearch/config/
投票数:138 平均点:5.80

なし Re: OSProfiles

msg# 1.5
前の投稿 - 次の投稿 | 親投稿 - 子投稿なし | 投稿日時 2010-7-25 4:50
skidz  Not too shy to talk   投稿数: 31
sorry.. I meant Hi Master :)
投票数:101 平均点:5.25

なし Re: OSProfiles

msg# 1.6
前の投稿 - 次の投稿 | 親投稿 - 子投稿なし | 投稿日時 2010-7-25 7:09
skidz  Not too shy to talk   投稿数: 31
I think my problem is with the database...

How should I set up the osprofiles and ossearch database?
Should I run both sql files for each in xoop cube database?
Do I run them both in a seperate database? say osmodules?
Do I not need to run the osprofiles sql? (I have not been, figured xoopensim, since it intraged did this)
投票数:79 平均点:4.81

なし Re: OSProfiles

msg# 1.7
前の投稿 - 次の投稿 | 親投稿 - 子投稿なし | 投稿日時 2010-7-25 7:27
skidz  Not too shy to talk   投稿数: 31
I have posted the exact bash script I am using to get this far..

http://www.skidzpartz.com/OSSearch.txt
http://www.skidzpartz.com/OSProfiles.txt
投票数:78 平均点:5.13

なし Re: OSProfiles

msg# 1.8
前の投稿 - 次の投稿 | 親投稿 - 子投稿なし | 投稿日時 2010-7-25 13:02
skidz  Not too shy to talk   投稿数: 31
Doing some more digging I found this in the Opensim.32Bitlauch.log file..

2010-07-24 22:46:00,402 ERROR - OpenSimProfile.Modules.OpenProfile.OpenProfileModule [PROFILE]: Unable to connect to Profile Server http://192.168.1.97/modules/xoopensim/helper/profile.php. Method avatar_properties_request, params System.Collections.Hashtable. Exception System.Xml.XmlException: Document element did not appear. Line 1, position 1.
at Mono.Xml2.XmlTextReader.Read () [0x00000]
at System.Xml.XmlTextReader.Read () [0x00000]
at Nwc.XmlRpc.XmlRpcResponseDeserializer.Deserialize (System.IO.TextReader xmlData) [0x00000]
at Nwc.XmlRpc.XmlRpcRequest.Send (System.String url, Int32 timeout) [0x00000]
at OpenSimProfile.Modules.OpenProfile.OpenProfileModule.GenericXMLRPCRequest (System.Collections.Hashtable ReqParams, System.String method) [0x00000]

I should mention, that this is a test server and all comms are behind my network, so even though I am using a local ip address it should still work...

Also when I go to the page manually myself I get no document at all, just a blank page.
投票数:245 平均点:3.80

なし Re: OSProfiles

msg# 1.9
前の投稿 - 次の投稿 | 親投稿 - 子投稿なし | 投稿日時 2010-7-25 13:10
skidz  Not too shy to talk   投稿数: 31
Another clue, I turned on php debugging.. and I get the following error on that page now...

Fatal error: Call to undefined function xmlrpc_server_create() in /home/opensim/var/www/modules/xoopensim/osprofile/webroot/profile.php on line 40
投票数:89 平均点:4.83

なし Re: OSProfiles

msg# 1.10
前の投稿 - 次の投稿 | 親投稿 - 子投稿なし | 投稿日時 2010-7-25 13:39
skidz  Not too shy to talk   投稿数: 31
Ahhh.. I just downloaded the full package, instead of via svn... and noticed, you don't even have the osprofiles 0.7 released yet, it must be something your still working on.. :)
投票数:119 平均点:5.80

なし Re: OSProfiles

msg# 1.11
前の投稿 - 次の投稿 | 親投稿 - 子投稿なし | 投稿日時 2010-7-25 16:27 | 最終変更
iseki  Home away from home   投稿数: 1581
Hi

At my site, osprofile is working well without ossearch. (OpenSim version is 0.7 and 0.7.1Dev)
XoopenSim is not support osearch now, but osprofile database is created automatically in XoopenSim.

>> Fatal error: Call to undefined function xmlrpc_server_create() in /home/opensim/var/www/modules/xoopensim/osprofile/webroot/profile.php on line 40

xmlrpc_server_create function is PHP's function.
If you compiled php, do you forget "--with-xmlrpc" option at configure command.

My configure commad options are

./configure --with-mysql=/usr/local/mysql --with-mysqli=/usr/local/mysql/bin/mysql_config \
--with-pdo-mysql=/usr/local/mysql \
--with-apxs2=/usr/local/apache/bin/apxs \
--enable-mbstring --with-zlib=/usr --with-iconv \
--with-openssl=/usr/local/ssl --with-curl --with-xmlrpc \
--with-gd --with-jpeg-dir --with-png-dir

Thanks.
投票数:99 平均点:5.56

なし Re: OSProfiles

msg# 1.12
前の投稿 - 次の投稿 | 親投稿 - 子投稿なし | 投稿日時 2010-7-25 17:57
skidz  Not too shy to talk   投稿数: 31
Hi iseki... Thanks

I didn't compile the php myself :) But I could see that being a good idea with the php requirements..

I did fix the error mentioned before by installing php5-xmlrpc again... that seemed to fix it..

But now I am getting the following error:
Notice [PHP]: Undefined variable: HTTP_RAW_POST_DATA in file modules/xoopensim/osprofile/webroot/profile.php line 680

I did disable debug and test, but I still receive the same error.

I also tried flushing my iptables since, I figured it might be a firewall problem

I did also figure out that to compile it you copy the osprofiles directory to opensim directory and use the the build.sh at that point.. before I was copying the contents from osprofiles to addon-modules :)

I am going to keep pounding on it.. see if I can figure it out..
投票数:145 平均点:5.10

なし Re: OSProfiles

msg# 1.13
前の投稿 - 次の投稿 | 親投稿 - 子投稿なし | 投稿日時 2010-7-25 18:13
iseki  Home away from home   投稿数: 1581
Hi skidz

HTTP_RAW_POST_DATA is PHP's variable, too.

Please see http://www.php.net/manual/en/reserved.variables.httprawpostdata.php

I think that there is a problem in the setting or installing of PHP.
投票数:116 平均点:3.45

なし Re: OSProfiles

msg# 1.14
前の投稿 - 次の投稿 | 親投稿 - 子投稿.1 | 投稿日時 2010-7-25 18:25
skidz  Not too shy to talk   投稿数: 31
I got it working! YES!

I did update the bash files I posted earlier with fixes :)

Thanks for putting up with me :) Still learning :)
投票数:139 平均点:6.76

なし Re: OSProfiles

msg# 1.14.1
前の投稿 - 次の投稿 | 親投稿 - 子投稿なし | 投稿日時 2010-8-1 5:59
master  Just can't stay away   投稿数: 138
Will it let you add in your pic ect and remember the changes?
Mine lets me put it all in but will not save it on .71 dev. Not sure where that problem comes from.
When i use the older project (we were using before) It loads everyones profiles but also cannot alter them.
So im getting confused with this a bit.
It seems to me one or the other should work but both have the same problem so might be a core thing too.
I have not tryed to build the xoopensim version because we already have users with profiles in them.
It is not a problem to start a fresh one as a user can make a new profile and be ok once i know what i should be using here.

tnx
投票数:153 平均点:3.40

なし Re: OSProfiles

msg# 1.15
前の投稿 - 次の投稿 | 親投稿 - 子投稿なし | 投稿日時 2010-8-1 20:25
master  Just can't stay away   投稿数: 138
Ahhh... yes ok i have it fixed now. What i needed to do was copy the profiles.cs from xoopensim to the opensim add-ons profile module.
then rebuild opensim normaly. It does not know i changed the .cs file so for me its an easy cheat.

Now both 1/2's of it are correct.
On testing all user profile settings are changeable and now remembers them.
Currently for me, setting the show in search dosent work(i think this is ignored in core) and when making a classified there is a popup about classifieds not available (it saves it anyway though).

Also it is using the orginal profiles data (osmodules db) that we already had.
:)
tnx
投票数:112 平均点:4.55

なし Re: OSProfiles

msg# 1.16
前の投稿 - 次の投稿 | 親投稿 - 子投稿.1 | 投稿日時 2011-10-21 4:51
Luisillo  Just can't stay away 居住地: Spain  投稿数: 80
Osprofiles partially fails with OpenSim 0.7.2 Release (Unix/Mono) and (Win/.NET)
picture fail
lap about :

picture fail
groups work ok
text fail
born fail

lap web: say No profile data
fail

lap interest: fail

lap pricks: work ok

lap classified: work ok

lap 1st life: fail

lap notes; work ok

Viewer: Hippo OpenSim Viewer 0.6.3 (LL 1.23.5) Apr 30 2010 22:08:16 (Hippo Release) I test with others with the same problems.

I try to uncomment relative code where fail for i can see errors in "error_log". Have not error.
Then I do db query manually and work fine but when open profile with viewer all again is updated deleting it.

XOOPS Cube Legacy 2.1.8
Regards,
投票数:77 平均点:3.90

なし Re: OSProfiles

msg# 1.16.1
前の投稿 - 次の投稿 | 親投稿 - 子投稿.1 | 投稿日時 2011-10-24 11:50
iseki  Home away from home   投稿数: 1581
Hi Luisillo,

Thank you for your report.

I'll check this problems.

But I'm very busy now. Correction may be overdue.

Thanks.
投票数:72 平均点:6.11

なし Re: OSProfiles

msg# 1.16.1.1
前の投稿 - 次の投稿 | 親投稿 - 子投稿.1 | 投稿日時 2011-11-9 10:15
iseki  Home away from home   投稿数: 1581
Hi

I am sorry to have kept you long waiting.

I am checking problems now.

Please wait a little more.
投票数:104 平均点:4.52

なし Re: OSProfiles

msg# 1.16.1.1.1
前の投稿 - 次の投稿 | 親投稿 - 子投稿なし | 投稿日時 2011-11-9 20:05 | 最終変更
iseki  Home away from home   投稿数: 1581
Hi Luisillo,

You need to rewrite [Profile] Section in config-include/Grid.ini (if you use Grid Mode).

[Profile]
    Module = "OpenProfileModule"
;    Module = "BasicProfileModule"

You may delete [Profile] section in OpenSim.ini, and add ProfileURL to config-include/Grid.ini



Furthermore, I mistook typo one character.

xoopensim/osprofile/webroot/profile.php L713

mistake: $firstImage = $req['FirstiLifeImage'];
correct: $firstImage = $req['FirstLifeImage'];

And you can download profile.php, too.
URL is http://www.nsl.tuis.ac.jp/DownLoad/SoftWare/PHP/WI-1.55/profile.php.gz

Thanks.
投票数:201 平均点:4.53

なし Re: OSProfiles

msg# 1.17
前の投稿 - 次の投稿 | 親投稿 - 子投稿なし | 投稿日時 2012-2-26 21:27
Luisillo  Just can't stay away 居住地: Spain  投稿数: 80
Thank you very much master!
投票数:102 平均点:6.08

  条件検索へ


サイト内 検索

ログイン

ユーザー名:

パスワード:


パスワード紛失
新規登録

サブ メニュー

ミニカレンダー

前月2024年 5月翌月
1 2 3 4
5 6 7 8 9 10 11
12 13 14 15 16 17 18
19 20 21 22 23 24 25
26 27 28 29 30 31
<今日>

オンライン状況

22 人のユーザが現在オンラインです。 (1 人のユーザが Forum を参照しています。)

登録ユーザ: 0
ゲスト: 22

もっと...

アクセスカウンタ

今日 : 4945494549454945
昨日 : 3958395839583958
総計 : 2370518823705188237051882370518823705188237051882370518823705188
Powered by XOOPS Cube 2.1© 2001-2006 XOOPS Cube Project
Design by XoopsDesign.com